Raspberry Pi 3 could be affected by Intel vulnerability

Intel vulnerability affects Raspberry Pi 3 security

2018 began with the unpleasant news of a serious vulnerability in Intel processors that would endanger the security of all systems and equipment that use this hardware. The security team of Google has recently discovered that such a problem not only affects computers with Intel chips but also computers with AMD hardware and even the ARM platform., the same one used by Raspberry Pi 3.

Despite that AMD and ARM platform teams insist Meltdown and Specter do not affect their hardware, the truth is Google has proven otherwise and therefore users should take action on it.

Both Microsoft and Apple and the Linux Kernel team are releasing updates to address this. Gnu / Linux distributions are also taking action on this, making it difficult or impossible for the Intel vulnerability to develop.

If we have Raspberry Pi 3 we can be affected by this problem, since we must not forget that the raspberry board uses ARM architecture. So one of the things we have to do is to update the operating system that we use in Raspberry Pi 3.

If we use the Raspberry Pi board as a personal home server, mostly we do not have to worry because many intruders will not be able to access it, but if we connect it to the Network and use it as a server, the problem may exist and therefore it is recommended use a good firewall or double authentication tools, it will not avoid the problem but it will make it more difficult for intruders to activate this vulnerability. If we are expert users, we can choose to download the 4.15 kernel code and compile it for Raspberry Pi 3. This will bring a momentary patch to this problem.

In any case, caution and software updates seem like the best tools to avoid falling prey to the Intel vulnerability. Do not you think?


The content of the article adheres to our principles of editorial ethics. To report an error click here!.

Be the first to comment

Leave a Comment

Your email address will not be published. Required fields are marked with *

*

*

  1. Responsible for the data: Miguel Ángel Gatón
  2. Purpose of the data: Control SPAM, comment management.
  3. Legitimation: Your consent
  4. Communication of the data: The data will not be communicated to third parties except by legal obligation.
  5. Data storage: Database hosted by Occentus Networks (EU)
  6. Rights: At any time you can limit, recover and delete your information.